Short but honestly good advise to rather pull boolean checks apart and re-group them as they make sense in the context of the given situation you’re checking for.

I started doing this when building an alert-check system for the company I’m working for right now, and it really helps organize what is a pre-condition, what a syntactical requirement, etc etc.

  • Valmond@lemmy.world
    link
    fedilink
    arrow-up
    1
    ·
    2 months ago

    Well it actually depends.

    Does it make the code more readable? Like you have several if statements using the same things (and/or else if)? Yeah then it’s probably good.

    If you have an if (work.lengt() == 0 && stacked_work.length() == 0) and that’s it, probably not. Depending of whats happining then of course.

    Be creative guys! But also dont be too creative :-) Think about the poor coder doing something with all that in a year or two, let’s make his life less miserable (It’s probably you, too).

    • overcast5348@lemmy.world
      link
      fedilink
      arrow-up
      2
      ·
      2 months ago

      “it actually depends”

      Yes, it depends. But in this scenario we’re not discussing if statements with one or two conditions. We’re exclusively discussing multiple complicated conditions. :)